Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2020-22219

Published: 22 August 2023

Buffer Overflow vulnerability in function bitwriter_grow_ in flac before 1.4.0 allows remote attackers to run arbitrary code via crafted input to the encoder.

Priority

Medium

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
flac
Launchpad, Ubuntu, Debian
focal
Released (1.3.3-1ubuntu0.2)
jammy
Released (1.3.3-2ubuntu0.2)
bionic
Released (1.3.2-1ubuntu0.1+esm1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
trusty
Released (1.3.0-2ubuntu0.14.04.1+esm2)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
xenial
Released (1.3.1-4ubuntu0.1~esm2)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
lunar Not vulnerable
(1.4.2+ds-2ubuntu1)
upstream
Released (1.4.0)
mantic Not vulnerable
(1.4.3+ds-2ubuntu1)
Patches:
upstream: https://github.com/xiph/flac/commit/21fe95ee828b0b9b944f6aa0bb02d24fbb981815

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H