Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!Close

CVE-2020-22043

Published: 1 June 2021

A Denial of Service vulnerability exists in FFmpeg 4.2 due to a memory leak at the fifo_alloc_common function in libavutil/fifo.c.

Priority

Medium

Cvss 3 Severity Score

6.5

Score breakdown

Status

Package Release Status
ffmpeg
Launchpad, Ubuntu, Debian
impish Not vulnerable
(7:4.4-6ubuntu5)
lunar Not vulnerable
(7:4.4.1-3ubuntu2)
groovy Not vulnerable
(7:4.3.1-4ubuntu1)
hirsute Not vulnerable

jammy Not vulnerable
(7:4.4.1-3ubuntu2)
kinetic Not vulnerable
(7:4.4.1-3ubuntu2)
trusty Does not exist

upstream
Released (4.3)
bionic
Released (7:3.4.11-0ubuntu0.1+esm2)
Available with Ubuntu Pro
focal
Released (7:4.2.7-0ubuntu0.1+esm2)
Available with Ubuntu Pro
xenial
Released (7:2.8.17-0ubuntu0.1+esm6)
Available with Ubuntu Pro
mantic Not vulnerable
(7:4.4.1-3ubuntu2)
Patches:
upstream: https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=b288a7eb3d963a175e177b6219c8271076ee8590

Severity score breakdown

Parameter Value
Base score 6.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H