CVE-2020-1934

Published: 01 April 2020

In Apache HTTP Server 2.4.0 to 2.4.41, mod_proxy_ftp may use uninitialized memory when proxying to a malicious FTP server.

Priority

Low

CVSS 3 base score: 5.3

Status

Package Release Status
apache2
Launchpad, Ubuntu, Debian
Upstream
Released (2.4.42)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2.4.43-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.4.41-4ubuntu3.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.4.29-1ubuntu4.14)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.4.18-2ubuntu3.17)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://svn.apache.org/viewvc?view=revision&revision=1873745
Upstream: https://github.com/apache/httpd/commit/179492ff35adbc239c2fcdcb3d6af117a11c105b