CVE-2020-17538

Published: 13 August 2020

A buffer overflow vulnerability in GetNumSameData() in contrib/lips4/gdevlips.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
ghostscript
Launchpad, Ubuntu, Debian
Upstream
Released (9.51~dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (9.50~dfsg-5ubuntu4.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (9.26~dfsg+0-0ubuntu0.18.04.13)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=9f39ed4a92578a020ae10459643e1fe72573d134