CVE-2020-1739

Published: 12 March 2020

A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.

Priority

Medium

CVSS 3 base score: 3.9

Status

Package Release Status
ansible
Launchpad, Ubuntu, Debian
Upstream
Released (2.9.7+dfsg-1, 1.7.2+dfsg-2+deb9u3)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.9.7+dfsg-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.9.7+dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa) Needed

Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed