CVE-2020-16589

Published: 09 December 2020

A head-based buffer overflow exists in Academy Software Foundation OpenEXR 2.3.0 in writeTileData in ImfTiledOutputFile.cpp that can cause a denial of service via a crafted EXR file.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
openexr
Launchpad, Ubuntu, Debian
Upstream
Released (2.5.3-2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.3.0-6ubuntu0.3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.2.0-11.1ubuntu1.4)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.2.0-10ubuntu2.4)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/AcademySoftwareFoundation/openexr/commit/6bb36714528a9563dd3b92720c5063a1284b86f8