CVE-2020-15305

Published: 26 June 2020

An issue was discovered in OpenEXR before 2.5.2. Invalid input could cause a use-after-free in DeepScanLineInputFile::DeepScanLineInputFile() in IlmImf/ImfDeepScanLineInputFile.cpp.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
openexr
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla)
Released (2.3.0-6ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.3.0-6ubuntu0.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.2.0-11.1ubuntu1.3)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.2.0-10ubuntu2.3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/AcademySoftwareFoundation/openexr/commit/3d03979dc101612e806cdf0b011475d9fa685a73