Your submission was sent successfully! Close

CVE-2020-14409

Published: 19 January 2021

SDL (Simple DirectMedia Layer) through 2.0.12 has an Integer Overflow (and resultant SDL_memcpy heap corruption) in SDL_BlitCopy in video/SDL_blit_copy.c via a crafted .BMP file.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
libsdl1.2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable

libsdl2
Launchpad, Ubuntu, Debian
Upstream
Released (2.0.14+dfsg2-2)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.0.14+dfsg2-3)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.0.14+dfsg2-3)
Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Needs triage

Patches:
Upstream: https://hg.libsdl.org/SDL/rev/3f9b4e92c1d9