CVE-2020-14392

Published: 11 September 2020

An untrusted pointer dereference flaw was found in Perl-DBI < 1.643. A local attacker who is able to manipulate calls to dbd_db_login6_sv() could cause memory corruption, affecting the service's availability.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
libdbi-perl
Launchpad, Ubuntu, Debian
Upstream
Released (1.643-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.643-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.640-1ubuntu0.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.634-1ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.630-1ubuntu0.1~esm1)
Ubuntu 12.04 ESM (Precise Pangolin)
Released (1.616-1ubuntu0.1)
Patches:
Upstream: https://github.com/perl5-dbi/dbi/commit/ea99b6aafb437db53c28fd40d5eafbe119cd66e1