Your submission was sent successfully! Close

CVE-2020-12654

Published: 5 May 2020

An issue was found in Linux kernel before 5.5.4. mwifiex_ret_wmm_get_status() in drivers/net/wireless/marvell/mwifiex/wmm.c allows a remote AP to trigger a heap-based buffer overflow because of an incorrect memcpy, aka CID-3a9b153c5591.

From the Ubuntu security team

It was discovered that the Marvell WiFi-Ex Driver in the Linux kernel did not properly validate status lengths in messages received from an access point, leading to a buffer overflow. A physically proximate attacker controlling an access point could use this to construct messages that could possibly result in arbitrary code execution.

Priority

High

CVSS 3 base score: 7.1

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-96.97)
eoan
Released (5.3.0-51.44)
focal Not vulnerable
(5.4.0-18.22)
groovy Not vulnerable
(5.4.0-26.30)
precise
Released (3.2.0-147.194)
trusty
Released (3.13.0-180.231)
upstream
Released (5.6~rc1)
xenial
Released (4.4.0-177.207)
Patches:
Introduced by

5e6e3a92b9a4c9416b17f468fa5c7fa2233b8b4e

Fixed by 3a9b153c5591548612c3955c9600a98150c81875
linux-aws
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1065.69)
eoan
Released (5.3.0-1017.18)
focal Not vulnerable
(5.4.0-1005.5)
groovy Not vulnerable
(5.4.0-1009.9)
precise Does not exist

trusty
Released (4.4.0-1065.69)
upstream
Released (5.6~rc1)
xenial
Released (4.4.0-1105.116)
linux-aws-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-aws-5.3
Launchpad, Ubuntu, Debian
bionic
Released (5.3.0-1017.18~18.04.1)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-aws-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.4.0-1018.18~18.04.1)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-aws-hwe
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial
Released (4.15.0-1065.69~16.04.1)
linux-azure
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
eoan
Released (5.3.0-1020.21)
focal Not vulnerable
(5.4.0-1006.6)
groovy Not vulnerable
(5.4.0-1010.10)
precise Does not exist

trusty
Released (4.15.0-1077.82~14.04.1)
upstream
Released (5.6~rc1)
xenial
Released (4.15.0-1077.82)
linux-azure-4.15
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1082.92)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-azure-5.3
Launchpad, Ubuntu, Debian
bionic
Released (5.3.0-1020.21~18.04.1)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-azure-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.4.0-1020.20~18.04.1)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-dell300x
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1005.8)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
eoan
Released (5.3.0-1018.19)
focal Not vulnerable
(5.4.0-1005.5)
groovy Not vulnerable
(5.4.0-1009.9)
precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial
Released (4.15.0-1060.64)
linux-gcp-4.15
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1071.81)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-gcp-5.3
Launchpad, Ubuntu, Debian
bionic
Released (5.3.0-1018.19~18.04.1)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-gcp-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.4.0-1019.19~18.04.2)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-gcp-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-gke-4.15
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1057.60)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
bionic
Released (5.0.0-1035.36)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-gke-5.3
Launchpad, Ubuntu, Debian
bionic
Released (5.3.0-1018.19~18.04.1)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-gke-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.4.0-1025.25~18.04.1)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-gkeop
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable
(5.4.0-1008.9)
groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-gkeop-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.4.0-1001.1)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic
Released (5.3.0-51.44~18.04.2)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial
Released (4.15.0-96.97~16.04.1)
linux-hwe-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.4.0-37.41~18.04.1)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-hwe-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable
(5.8.0-23.24~20.04.1)
groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Ignored
(was needs-triage now end-of-life)
linux-kvm
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1058.59)
eoan
Released (5.3.0-1016.17)
focal Not vulnerable
(5.4.0-1004.4)
groovy Not vulnerable
(5.4.0-1009.9)
precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial
Released (4.4.0-1069.76)
linux-lts-trusty
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

precise
Released (3.13.0-180.231~12.04.1)
trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty
Released (4.4.0-177.207~14.04.1)
upstream
Released (5.6~rc1)
xenial Does not exist

linux-oem
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1079.89)
eoan Ignored
(was pending \[4.15.0-1079.89\] now end-of-life)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Ignored
(was needs-triage now end-of-life)
linux-oem-5.10
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable
(5.10.0-1008.9)
groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-oem-5.6
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Does not exist

focal Not vulnerable
(5.6.0-1007.7)
groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-oem-osp1
Launchpad, Ubuntu, Debian
bionic
Released (5.0.0-1050.55)
eoan Ignored
(was pending \[5.0.0-1059.64\] now end-of-life)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-oracle
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1037.41)
eoan
Released (5.3.0-1016.18)
focal Not vulnerable
(5.4.0-1005.5)
groovy Not vulnerable
(5.4.0-1009.9)
precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial
Released (4.15.0-1037.41~16.04.1)
linux-oracle-5.0
Launchpad, Ubuntu, Debian
bionic Ignored
(was needs-triage now end-of-life)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-oracle-5.3
Launchpad, Ubuntu, Debian
bionic
Released (5.3.0-1016.18~18.04.1)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-oracle-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.4.0-1019.19~18.04.1)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-raspi
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Does not exist

focal Not vulnerable
(5.4.0-1007.7)
groovy Not vulnerable
(5.4.0-1008.8)
precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-raspi-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.4.0-1013.13~18.04.1)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-raspi2
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1060.64)
eoan
Released (5.3.0-1023.25)
focal Ignored
(was needs-triage now end-of-life)
groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial
Released (4.4.0-1131.140)
linux-raspi2-5.3
Launchpad, Ubuntu, Debian
bionic
Released (5.3.0-1023.25~18.04.1)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-riscv
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Does not exist

focal Not vulnerable
(5.4.0-24.28)
groovy Not vulnerable
(5.4.0-24.28)
precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial Does not exist

linux-snapdragon
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1076.83)
eoan Does not exist

focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (5.6~rc1)
xenial
Released (4.4.0-1135.143)