CVE-2020-11041

Published: 29 May 2020

In FreeRDP less than or equal to 2.0.0, an outside controlled array index is used unchecked for data used as configuration for sound backend (alsa, oss, pulse, ...). The most likely outcome is a crash of the client instance followed by no or distorted sound or a session disconnect. If a user cannot upgrade to the patched version, a workaround is to disable sound for the session. This has been patched in 2.1.0.

Priority

Medium

CVSS 3 base score: 2.7

Status

Package Release Status
freerdp
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

freerdp2
Launchpad, Ubuntu, Debian
Upstream
Released (2.1.1+dfsg1-1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.1.1+dfsg1-0ubuntu0.20.04.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.1.1+dfsg1-0ubuntu0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/FreeRDP/FreeRDP/commit/2215fef975b963b3995356c3583f0e87cd08ac6b