CVE-2020-10938

Published: 24 March 2020

GraphicsMagick before 1.3.35 has an integer overflow and resultant heap-based buffer overflow in HuffmanDecodeImage in magick/compress.c.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
graphicsmagick
Launchpad, Ubuntu, Debian
Upstream
Released (1.4+really1.3.34-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.4+really1.3.34+hg16181-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.4+really1.3.34+hg16181-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.4+really1.3.34+hg16181-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Needs triage