Your submission was sent successfully! Close

CVE-2020-10018

Published: 2 March 2020

WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
qtwebkit
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Ignored
(reached end-of-life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

qtwebkit-opensource-src
Launchpad, Ubuntu, Debian
bionic Needs triage

eoan Ignored
(reached end-of-life)
focal Needs triage

groovy Ignored
(reached end-of-life)
hirsute Ignored
(reached end-of-life)
impish Needs triage

jammy Needs triage

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Needs triage

qtwebkit-source
Launchpad, Ubuntu, Debian
bionic Needs triage

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Ignored
(end of standard support, was needs-triage)
webkit2gtk
Launchpad, Ubuntu, Debian
bionic
Released (2.28.0-0ubuntu0.18.04.3)
eoan
Released (2.28.0-0ubuntu0.19.10.2)
focal
Released (2.28.0-1ubuntu2)
groovy
Released (2.28.0-1ubuntu2)
hirsute
Released (2.28.0-1ubuntu2)
impish
Released (2.28.0-1ubuntu2)
jammy
Released (2.28.0-1ubuntu2)
precise Does not exist

trusty Does not exist

upstream
Released (2.28.0)
xenial Deferred

webkitgtk
Launchpad, Ubuntu, Debian
bionic Needs triage

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Ignored
(end of standard support, was needs-triage)

Notes

AuthorNote
jdstrand
webkit receives limited support. For details, see
https://wiki.ubuntu.com/SecurityTeam/FAQ#webkit
webkit in Ubuntu uses the JavaScriptCore (JSC) engine, not V8

References

Bugs