Your submission was sent successfully! Close

CVE-2019-9644

Published: 12 March 2019

An XSSI (cross-site inclusion) vulnerability in Jupyter Notebook before 5.7.6 allows inclusion of resources on malicious pages when visited by users who are authenticated with a Jupyter server. Access to the content of resources has been demonstrated with Internet Explorer through capturing of error messages, though not reproduced with other browsers. This occurs because Internet Explorer's error messages can include the content of any invalid JavaScript that was encountered.

Priority

Medium

CVSS 3 base score: 5.4

Status

Package Release Status
jupyter-notebook
Launchpad, Ubuntu, Debian
bionic
Released (5.2.2-1ubuntu0.1)
cosmic Ignored
(reached end-of-life)
disco Ignored
(reached end-of-life)
eoan Not vulnerable
(5.7.8-1)
focal Not vulnerable
(5.7.8-1)
groovy Not vulnerable
(5.7.8-1)
hirsute Not vulnerable
(5.7.8-1)
impish Not vulnerable
(5.7.8-1)
jammy Not vulnerable
(5.7.8-1)
precise Does not exist

trusty Does not exist

upstream
Released (5.7.6)
xenial Does not exist