CVE-2019-9589

Published: 06 March 2019

There is a NULL pointer dereference vulnerability in PSOutputDev::setupResources() located in PSOutputDev.cc in Xpdf 4.01. It can be triggered by sending a crafted pdf file to (for example) the pdftops binary. It allows an attacker to cause Denial of Service (Segmentation fault) or possibly have unspecified other impact.

Priority

Low

CVSS 3 base score: 7.8

Status

Package Release Status
ipe
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(code not present)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(code not present)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(code not present)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)
libextractor
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(code not present)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(code not present)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(code not present)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)
poppler
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.76.1-0ubuntu3)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.76.1-0ubuntu3)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.76.1-0ubuntu3)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.62.0-2ubuntu2.8)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(0.41.0-0ubuntu1.13)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)
texlive-bin
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2018.20181218.49446-2)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2018.20181218.49446-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2018.20181218.49446-2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)
utopia-documents
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

xpdf
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Needs triage

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)

Notes

AuthorNote
jdstrand
xpdf in koffice is 2.0
mdeslaur
can't reproduce with poppler, no indication it is affected
code is different in texlive-bin, doesn't look vulnerable
ebarretto
since 0.5.12-1 libextractor does not use xpdf anymore.

References