Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2019-8518

Published: 11 April 2019

Multiple memory corruption issues were addressed with improved memory handling. This issue is fixed in iOS 12.2, tvOS 12.2, watchOS 5.2, Safari 12.1, iTunes 12.9.4 for Windows, iCloud for Windows 7.11. Processing maliciously crafted web content may lead to arbitrary code execution.

Notes

AuthorNote
jdstrand
webkit receives limited support. For details, see
https://wiki.ubuntu.com/SecurityTeam/FAQ#webkit
webkit in Ubuntu uses the JavaScriptCore (JSC) engine, not V8

Priority

Medium

Cvss 3 Severity Score

8.8

Score breakdown

Status

Package Release Status
qtwebkit
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

eoan Ignored
(reached end-of-life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

qtwebkit-opensource-src
Launchpad, Ubuntu, Debian
bionic Needs triage

cosmic Ignored
(reached end-of-life)
disco Ignored
(reached end-of-life)
eoan Ignored
(reached end-of-life)
focal Needs triage

groovy Ignored
(reached end-of-life)
hirsute Ignored
(reached end-of-life)
impish Ignored
(reached end-of-life)
jammy Needs triage

kinetic Needs triage

precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream Needs triage

xenial Needs triage

qtwebkit-source
Launchpad, Ubuntu, Debian
bionic Needs triage

cosmic Ignored
(reached end-of-life)
disco Ignored
(reached end-of-life)
eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream Needs triage

xenial Needs triage

webkit2gtk
Launchpad, Ubuntu, Debian
bionic
Released (2.24.1-0ubuntu0.18.04.1)
cosmic
Released (2.24.1-0ubuntu0.18.10.2)
disco Not vulnerable
(2.24.1-1)
eoan Not vulnerable
(2.24.1-1)
focal Not vulnerable
(2.24.1-1)
groovy Not vulnerable
(2.24.1-1)
hirsute Not vulnerable
(2.24.1-1)
impish Not vulnerable
(2.24.1-1)
jammy Not vulnerable
(2.24.1-1)
kinetic Not vulnerable
(2.24.1-1)
precise Does not exist

trusty Does not exist

upstream
Released (2.22.7)
xenial Deferred

webkitgtk
Launchpad, Ubuntu, Debian
bionic Needs triage

cosmic Ignored
(reached end-of-life)
disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream Needs triage

xenial Needs triage

Severity score breakdown

Parameter Value
Base score 8.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H