CVE-2019-8457

Published: 31 May 2019

SQLite3 from 3.6.0 to and including 3.27.2 is vulnerable to heap out-of-bound read in the rtreenode() function when handling invalid rtree tables.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
chromium
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

db5.3
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla)
Released (5.3.28+dfsg1-0.6ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (5.3.28+dfsg1-0.6ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (5.3.28-13.1ubuntu1.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (5.3.28-11ubuntu0.2)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (5.3.28-3ubuntu3.1+esm1)
qtwebengine-opensource-src
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

sqlcipher
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Needed

Ubuntu 20.04 LTS (Focal Fossa) Needed

Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

sqlite3
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla)
Released (3.27.2-3)
Ubuntu 20.04 LTS (Focal Fossa)
Released (3.27.2-3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.22.0-1ubuntu0.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (3.11.0-1ubuntu1.2)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (3.8.2-1ubuntu2.2+esm1)