Your submission was sent successfully! Close

CVE-2019-6956

Published: 25 January 2019

An issue was discovered in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. It is a buffer over-read in ps_mix_phase in libfaad/ps_dec.c.

From the Ubuntu security team

It was discovered that Freeware Advanced Audio Decoder 2 incorrectly handled certain mp4 files. An attacker could possibly use this issue to cause a denial of service.

Priority

Medium

CVSS 3 base score: 7.1

Status

Package Release Status
faad2
Launchpad, Ubuntu, Debian
bionic Needed

cosmic Ignored
(reached end-of-life)
disco Ignored
(reached end-of-life)
eoan Not vulnerable
(2.8.8-3.2)
focal Not vulnerable
(2.8.8-3.2)
groovy Not vulnerable
(2.8.8-3.2)
hirsute Not vulnerable
(2.8.8-3.2)
impish Not vulnerable
(2.8.8-3.2)
jammy Not vulnerable
(2.8.8-3.2)
precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream
Released (2.7-8+deb8u3)
xenial Ignored
(end of standard support, was needed)
Patches:
upstream: https://github.com/knik0/faad2/commit/6823e6610c9af1b0080cb22b9da03efb208d7d57