Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2019-5063

Published: 3 January 2020

An exploitable heap buffer overflow vulnerability exists in the data structure persistence functionality of OpenCV 4.1.0. A specially crafted XML file can cause a buffer overflow, resulting in multiple heap corruptions and potential code execution. An attacker can provide a specially crafted file to trigger this vulnerability.

Notes

AuthorNote
ccdm94
in bionic and earlier, functions fixed by commit are in
file modules/core/src/persistence.cpp instead of the ones
presented in the upstream patch. However, upstream
reports that versions 3.4.8 and older are not affected,
due to code refactoring. See: https://github.com/opencv/
opencv/issues/15857.

Priority

Medium

Cvss 3 Severity Score

8.8

Score breakdown

Status

Package Release Status
opencv
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
disco Ignored
(end of life)
eoan Ignored
(end of life)
focal Not vulnerable
(4.2.0+dfsg-5)
groovy Ignored
(end of life)
jammy Not vulnerable
(4.5.4+dfsg-9ubuntu4)
trusty Not vulnerable
(code not present)
upstream
Released (4.2.0)
xenial Ignored
(end of standard support, was not-affected [code not present])
Patches:
upstream: https://github.com/opencv/opencv/commit/f42d5399aac80d371b17d689851406669c9b9111

Severity score breakdown

Parameter Value
Base score 8.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H