Your submission was sent successfully! Close

CVE-2019-5058

Published: 31 July 2019

An exploitable code execution vulnerability exists in the XCF image rendering functionality of SDL2_image 2.0.4. A specially crafted XCF image can cause a heap overflow, resulting in code execution. An attacker can display a specially crafted image to trigger this vulnerability.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
libsdl2-image
Launchpad, Ubuntu, Debian
Upstream
Released (2.0.5+dfsg1-1, 2.0.4+dfsg1-1+deb10u1, 2.0.1+dfsg-2+deb9u2, 2.0.0+dfsg-3+deb8u2)
Ubuntu 21.10 (Impish Indri)
Released (2.0.5+dfsg1-1)
Ubuntu 21.04 (Hirsute Hippo)
Released (2.0.5+dfsg1-1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.0.5+dfsg1-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist