CVE-2019-3886

Published: 04 April 2019

An incorrect permissions check was discovered in libvirt 4.8.0 and above. The readonly permission was allowed to invoke APIs depending on the guest agent, which could lead to potentially disclosing unintended information or denial of service by causing libvirt to block.

Priority

Low

CVSS 3 base score: 5.4

Status

Package Release Status
libvirt
Launchpad, Ubuntu, Debian
Upstream
Released (5.0.0-2)
Ubuntu 21.04 (Hirsute Hippo)
Released (5.4.0-0ubuntu1)
Ubuntu 20.10 (Groovy Gorilla)
Released (5.4.0-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (5.4.0-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
Patches:
Upstream: https://libvirt.org/git/?p=libvirt.git;a=commit;h=2a07c990bd9143d7a0fe8d1b6b7c763c52185240
Upstream: https://libvirt.org/git/?p=libvirt.git;a=commit;h=ae076bb40e0e150aef41361b64001138d04d6c60