CVE-2019-3878

Published: 21 March 2019

A vulnerability was found in mod_auth_mellon before v0.14.2. If Apache is configured as a reverse proxy and mod_auth_mellon is configured to only let through authenticated users (with the require valid-user directive), adding special HTTP headers that are normally used to start the special SAML ECP (non-browser based) can be used to bypass authentication.

Priority

Medium

CVSS 3 base score: 8.1

Status

Package Release Status
libapache2-mod-auth-mellon
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla)
Released (0.14.2-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (0.14.2-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.13.1-1ubuntu0.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (0.12.0-2+deb9u1build0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)
Ubuntu 12.04 ESM (Precise Pangolin) Does not exist

Patches:
Upstream: https://github.com/Uninett/mod_auth_mellon/commit/e09a28a30e13e5c22b481010f26b4a7743a09280