Your submission was sent successfully! Close

CVE-2019-3855

Published: 21 March 2019

An integer overflow flaw which could lead to an out of bounds write was discovered in libssh2 before 1.8.1 in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to execute code on the client system when a user connects to the server.

From the Ubuntu security team

It was discovered that libssh2 mishandled certain input. If libssh2 were used to connect to a malicious or compromised SSH server, a remote, unauthenticated attacker could execute arbitrary code on the client system.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
libssh2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.8.0-2.1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.8.0-2.1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.8.0-2.1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed