CVE-2019-25037

Published: 27 April 2021

Unbound before 1.9.5 allows an assertion failure and denial of service in dname_pkt_copy via an invalid packet.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
unbound
Launchpad, Ubuntu, Debian
Upstream
Released (1.9.6-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.11.0-1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (1.9.4-2ubuntu1.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.6.7-1ubuntu2.4)
Ubuntu 16.04 ESM (Xenial Xerus) Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Needs triage

Patches:
Upstream: https://github.com/NLnetLabs/unbound/commit/d2eb78e871153f22332d30c6647f3815148f21e5