CVE-2019-2228

Published: 06 December 2019

In array_find of array.c, there is a possible out-of-bounds read due to an incorrect bounds check. This could lead to local information disclosure in the printer spooler with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-8.0 Android-8.1 Android-9 Android-10Android ID: A-111210196

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
cups
Launchpad, Ubuntu, Debian
Upstream
Released (2.3.1-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2.3.1-4)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.3.1-4)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.2.7-1ubuntu2.8)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.1.3-4ubuntu0.11)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Ubuntu 12.04 ESM (Precise Pangolin) Does not exist

Patches:
Upstream: https://github.com/apple/cups/commit/b018978c278d42c7abf78941251b887c95dfdb07 (2.3.1)
Upstream: https://github.com/apple/cups/commit/8c9b3606cca99e5dfc51784a9de1634345db7579 (2.2.13)