CVE-2019-20445

Published: 29 January 2020

HttpObjectDecoder.java in Netty before 4.1.44 allows a Content-Length header to be accompanied by a second Content-Length header, or by a Transfer-Encoding header.

From the Ubuntu security team

It was discovered that Netty has HTTP request smuggling vulnerability. A remote attacker could use it to extract sensitive information.

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
netty
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1:4.1.45-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1:4.1.45-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 LTS (Xenial Xerus) Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Needs triage

Ubuntu 12.04 ESM (Precise Pangolin) Does not exist

netty-3.9
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.9.9.Final-1+deb9u1build0.18.04.1)
Ubuntu 16.04 LTS (Xenial Xerus) Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Ubuntu 12.04 ESM (Precise Pangolin) Does not exist