Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2019-20016

Published: 27 December 2019

libmysofa before 2019-11-24 does not properly restrict recursive function calls, as demonstrated by reports of stack consumption in readOHDRHeaderMessageDatatype in dataobject.c and directblockRead in fractalhead.c. NOTE: a download of v0.9 after 2019-12-06 should fully remediate this issue.

Priority

Medium

Cvss 3 Severity Score

6.5

Score breakdown

Status

Package Release Status
libmysofa
Launchpad, Ubuntu, Debian
bionic Needed

disco Ignored
(end of life)
eoan Ignored
(end of life)
focal Not vulnerable
(0.9~dfsg0-1)
groovy Not vulnerable
(0.9~dfsg0-1)
hirsute Not vulnerable
(0.9~dfsg0-1)
impish Not vulnerable
(0.9~dfsg0-1)
jammy Not vulnerable
(0.9~dfsg0-1)
kinetic Not vulnerable
(0.9~dfsg0-1)
lunar Not vulnerable
(0.9~dfsg0-1)
mantic Not vulnerable
(0.9~dfsg0-1)
trusty Does not exist

upstream
Released (0.9~dfsg0-1)
xenial Does not exist

Severity score breakdown

Parameter Value
Base score 6.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H