Your submission was sent successfully! Close

CVE-2019-19962

Published: 25 December 2019

wolfSSL before 4.3.0 mishandles calls to wc_SignatureGenerateHash, leading to fault injection in RSA cryptography.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
wolfssl
Launchpad, Ubuntu, Debian
Upstream
Released (4.3.0+dfsg-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.3.0+dfsg-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.3.0+dfsg-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.3.0+dfsg-2)
Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist