CVE-2019-19919

Published: 20 December 2019

Versions of handlebars prior to 4.3.0 are vulnerable to Prototype Pollution leading to Remote Code Execution. Templates may alter an Object's __proto__ and __defineGetter__ properties, which may allow an attacker to execute arbitrary code through crafted payloads.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
node-handlebars
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(3:4.5.3-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(3:4.5.3-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3:4.5.3-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist