CVE-2019-19709

Published: 11 December 2019

MediaWiki through 1.33.1 allows attackers to bypass the Title_blacklist protection mechanism by starting with an arbitrary title, establishing a non-resolvable redirect for the associated page, and using redirect=1 in the action API when editing that page.

Priority

Low

CVSS 3 base score: 6.1

Status

Package Release Status
mediawiki
Launchpad, Ubuntu, Debian
Upstream
Released (1:1.32.6-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1:1.31.6-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1:1.31.6-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1:1.31.6-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist