CVE-2019-19630

Published: 08 December 2019

HTMLDOC 1.9.7 allows a stack-based buffer overflow in the hd_strlcpy() function in string.c (when called from render_contents in ps-pdf.cxx) via a crafted HTML document.

From the Ubuntu security team

It was dicovered that HTMLDOC has a stack-based buffer overflow vulnerability. An attacker could use it create a crafted HTML document that provoke a Denial of Service.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
htmldoc
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.9.7-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.9.7-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.9.7-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.9.2-1ubuntu0.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.8.27-8ubuntu1.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist