CVE-2019-19604

Published: 10 December 2019

Arbitrary command execution is possible in Git before 2.20.2, 2.21.x before 2.21.1, 2.22.x before 2.22.2, 2.23.x before 2.23.1, and 2.24.x before 2.24.1 because a "git submodule update" operation can run commands found in the .gitmodules file of a malicious repository.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
git
Launchpad, Ubuntu, Debian
Upstream
Released (1:2.24.0-2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (1:2.25.0-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.17.1-1ubuntu0.4)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(2.7.4-0ubuntu1.6)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist