CVE-2019-19344

Published: 21 January 2020

There is a use-after-free issue in all samba 4.9.x versions before 4.9.18, all samba 4.10.x versions before 4.10.12 and all samba 4.11.x versions before 4.11.5, essentially due to a call to realloc() while other local variables still point at the original buffer.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
samba
Launchpad, Ubuntu, Debian
Upstream
Released (4.11.5,4.10.12)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2:4.11.5+dfsg-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2:4.7.6+dfsg~ubuntu-0ubuntu2.14)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(2:4.3.11+dfsg-0ubuntu0.16.04.24)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable

Ubuntu 12.04 ESM (Precise Pangolin) Not vulnerable