Your submission was sent successfully! Close

CVE-2019-19246

Published: 25 November 2019

Oniguruma through 6.9.3, as used in PHP 7.3.x and other products, has a heap-based buffer over-read in str_lower_case_match in regexec.c.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
libonig
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(6.9.4-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(6.9.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(6.9.4-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (5.9.1-1ubuntu1.1+esm2)