CVE-2019-17542

Published: 14 October 2019

FFmpeg before 4.2 has a heap-based buffer overflow in vqa_decode_chunk because of an out-of-array access in vqa_decode_init in libavcodec/vqavideo.c.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
ffmpeg
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(7:4.2.1-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(7:4.2.1-2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (7:3.4.8-0ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (7:2.8.17-0ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/FFmpeg/FFmpeg/commit/02f909dc24b1f05cfbba75077c7707b905e63cd2