CVE-2019-17358

Published: 12 December 2019

Cacti through 1.2.7 is affected by multiple instances of lib/functions.php unsafe deserialization of user-controlled data to populate arrays. An authenticated attacker could use this to influence object data values and control actions taken by Cacti or potentially cause memory corruption in the PHP module.

Priority

Medium

CVSS 3 base score: 8.1

Status

Package Release Status
cacti
Launchpad, Ubuntu, Debian
Upstream
Released (0.8.8b+dfsg-8+deb8u8, 1.2.8+ds1-1)
Ubuntu 20.10 (Groovy Gorilla) Needed

Ubuntu 20.04 LTS (Focal Fossa) Needed

Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist