Your submission was sent successfully! Close

CVE-2019-17005

Published: 4 December 2019

The plain text serializer used a fixed-size array for the number of <ol> elements it could process; however it was possible to overflow the static-sized array leading to memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 68.3, Firefox ESR < 68.3, and Firefox < 71.

Notes

AuthorNote
tyhicks
mozjs contains a copy of the SpiderMonkey JavaScript engine
Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
bionic
Released (71.0+build5-0ubuntu0.18.04.1)
disco
Released (71.0+build5-0ubuntu0.19.04.1)
eoan
Released (71.0+build5-0ubuntu0.19.10.1)
focal
Released (71.0+build5-0ubuntu1)
groovy
Released (71.0+build5-0ubuntu1)
hirsute
Released (71.0+build5-0ubuntu1)
impish
Released (71.0+build5-0ubuntu1)
jammy
Released (71.0+build5-0ubuntu1)
precise Does not exist

trusty Does not exist

upstream
Released (71.0)
xenial
Released (71.0+build5-0ubuntu0.16.04.1)
mozjs38
Launchpad, Ubuntu, Debian
bionic Needs triage

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs52
Launchpad, Ubuntu, Debian
bionic Needs triage

disco Ignored
(reached end-of-life)
eoan Ignored
(reached end-of-life)
focal Needs triage

groovy Ignored
(reached end-of-life)
hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs60
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Ignored
(reached end-of-life)
eoan Ignored
(reached end-of-life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

thunderbird
Launchpad, Ubuntu, Debian
bionic
Released (1:68.4.1+build1-0ubuntu0.18.04.1)
disco Ignored
(reached end-of-life)
eoan
Released (1:68.4.1+build1-0ubuntu0.19.10.1)
focal
Released (1:68.3.0+build2-0ubuntu1)
groovy
Released (1:68.3.0+build2-0ubuntu1)
hirsute
Released (1:68.3.0+build2-0ubuntu1)
impish
Released (1:68.3.0+build2-0ubuntu1)
jammy
Released (1:68.3.0+build2-0ubuntu1)
precise Does not exist

trusty Does not exist

upstream
Released (68.3)
xenial
Released (1:68.7.0+build1-0ubuntu0.16.04.2)