CVE-2019-16718

Published: 23 September 2019

In radare2 before 3.9.0, a command injection vulnerability exists in bin_symbols() in libr/core/cbin.c. By using a crafted executable file, it's possible to execute arbitrary shell commands with the permissions of the victim. This vulnerability is due to an insufficient fix for CVE-2019-14745 and improper handling of symbol names embedded in executables.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
radare2
Launchpad, Ubuntu, Debian
Upstream
Released (3.9.0)
Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4.2.1+dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.2.1+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist