Your submission was sent successfully! Close

CVE-2019-15296

Published: 21 August 2019

An issue was discovered in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The faad_resetbits function in libfaad/bits.c is affected by a buffer overflow vulnerability. The number of bits to be read is determined by ld->buffer_size - words*4, cast to uint32. If ld->buffer_size - words*4 is negative, a buffer overflow is later performed via getdword_n(&ld->start[words], ld->bytes_left).

From the Ubuntu security team

It was discovered that Freeware Advanced Audio Decoder 2 incorrectly handled certain mp4 files. An attacker could possibly use this issue to cause a denial of service.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
faad2
Launchpad, Ubuntu, Debian
bionic Needed

disco Ignored
(reached end-of-life)
eoan Not vulnerable
(2.8.8-3ubuntu3)
focal Not vulnerable
(2.8.8-3ubuntu3)
groovy Not vulnerable
(2.8.8-3ubuntu3)
hirsute Not vulnerable
(2.8.8-3ubuntu3)
impish Not vulnerable
(2.8.8-3ubuntu3)
jammy Not vulnerable
(2.8.8-3ubuntu3)
precise Does not exist

trusty Does not exist

upstream
Released (2.8.8-3)
xenial Ignored
(end of standard support, was needed)
Patches:
upstream: https://github.com/knik0/faad2/commit/942c3e0aee748ea6fe97cb2c1aa5893225316174