CVE-2019-14934

Published: 11 August 2019

An issue was discovered in PDFResurrect before 0.18. pdf_load_pages_kids in pdf.c doesn't validate a certain size value, which leads to a malloc failure and out-of-bounds write.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
pdfresurrect
Launchpad, Ubuntu, Debian
Upstream
Released (0.18-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.18-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.18-2)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist