CVE-2019-14864

Published: 02 January 2020

Ansible, versions 2.9.x before 2.9.1, 2.8.x before 2.8.7 and Ansible versions 2.7.x before 2.7.15, is not respecting the flag no_log set it to True when Sumologic and Splunk callback plugins are used send tasks results events to collectors. This would discloses and collects any sensitive data.

Priority

Low

CVSS 3 base score: 6.5

Status

Package Release Status
ansible
Launchpad, Ubuntu, Debian
Upstream
Released (2.9.2+dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.9.2+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)