Your submission was sent successfully! Close

CVE-2019-14846

Published: 08 October 2019

In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

Priority

Low

CVSS 3 base score: 7.8

Status

Package Release Status
ansible
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.8.6+dfsg-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.8.6+dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.8.6+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Needs triage