Your submission was sent successfully! Close

CVE-2019-14833

Published: 29 October 2019

A flaw was found in Samba, all versions starting samba 4.5.0 before samba 4.9.15, samba 4.10.10, samba 4.11.2, in the way it handles a user password change or a new password for a samba user. The Samba Active Directory Domain Controller can be configured to use a custom script to check for password complexity. This configuration can fail to verify password complexity when non-ASCII characters are used in the password, which could lead to weak passwords being set for samba users, making it vulnerable to dictionary attacks.

Priority

Medium

CVSS 3 base score: 5.4

Status

Package Release Status
samba
Launchpad, Ubuntu, Debian
Upstream
Released (4.11.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2:4.7.6+dfsg~ubuntu-0ubuntu2.13)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:4.3.11+dfsg-0ubuntu0.16.04.21)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable