Your submission was sent successfully! Close

CVE-2019-14818

Published: 12 November 2019

A flaw was found in all dpdk version 17.x.x before 17.11.8, 16.x.x before 16.11.10, 18.x.x before 18.11.4 and 19.x.x before 19.08.1 where a malicious master, or a container with access to vhost_user socket, can send specially crafted VRING_SET_NUM messages, resulting in a memory leak including file descriptors. This flaw could lead to a denial of service condition.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
dpdk
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(18.11.4-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(18.11.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(18.11.4-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (17.11.8-0~ubuntu18.04.2)
Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist