Your submission was sent successfully! Close

CVE-2019-14751

Published: 20 August 2019

NLTK Downloader before 3.4.5 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in an NLTK package (ZIP archive) that is mishandled during extraction.

From the Ubuntu security team

It was discovered that NLTK mishandled crafted ZIP archives during extraction. A remote attacker could use this vulnerability to write arbitrary files to the filesystem

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
nltk
Launchpad, Ubuntu, Debian
bionic
Released (3.2.5-1ubuntu0.1)
disco
Released (3.4-1ubuntu0.1)
precise Does not exist

trusty Does not exist

upstream
Released (3.4.5)
xenial
Released (3.1-1ubuntu0.1)