Your submission was sent successfully! Close

CVE-2019-14463

Published: 31 July 2019

An issue was discovered in libmodbus before 3.0.7 and 3.1.x before 3.1.5. There is an out-of-bounds read for the MODBUS_FC_WRITE_MULTIPLE_REGISTERS case, aka VD-1301.

From the Ubuntu security team

It was discovered that libmodbus incorrectly handled inputs. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
libmodbus
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(3.1.6-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(3.1.6-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.1.6-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.0.6-2+deb9u1build0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://github.com/stephane/libmodbus/commit/5ccdf5ef79d742640355d1132fa9e2abc7fbaefc (3.1.5)
Upstream: https://github.com/stephane/libmodbus/commit/ca3fcb1c98755e8f44c33a910af4db3c799ee63e (3.1.5)
Upstream: https://github.com/stephane/libmodbus/commit/6f915d4215c06be3c719761423d9b5e8aa3cb820 (3.1.5)
Upstream: https://github.com/stephane/libmodbus/commit/2b5cb5896120d7564f4c34fdc5aaa4f22a97e45c (3.0.7)
Upstream: https://github.com/stephane/libmodbus/commit/64cd092bcc421a70431fe1fb6b7f1e6f491f7cf8 (3.0.8)