CVE-2019-14444

Published: 30 July 2019

apply_relocations in readelf.c in GNU Binutils 2.32 contains an integer overflow that allows attackers to trigger a write access violation (in byte_put_little_endian function in elfcomm.c) via an ELF file, as demonstrated by readelf.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
binutils
Launchpad, Ubuntu, Debian
Upstream
Released (2.32.51.20190813-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2.34-5ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.34-5ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.30-21ubuntu1~18.04.3)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=e17869db99195849826eaaf5d2d0eb2cfdd7a2a7