Your submission was sent successfully! Close

CVE-2019-14317

Published: 11 December 2019

wolfSSL and wolfCrypt 4.1.0 and earlier (formerly known as CyaSSL) generate biased DSA nonces. This allows a remote attacker to compute the long term private key from several hundred DSA signatures via a lattice attack. The issue occurs because dsa.c fixes two bits of the generated nonces.

Priority

Medium

CVSS 3 base score: 5.3

Status

Package Release Status
wolfssl
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.2.0+dfsg-3)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.2.0+dfsg-3)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.2.0+dfsg-3)
Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist