CVE-2019-1387

Published: 10 December 2019

An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. Recursive clones are currently affected by a vulnerability that is caused by too-lax validation of submodule names, allowing very targeted attacks via remote code execution in recursive clones.

Priority

Low

CVSS 3 base score: 8.8

Status

Package Release Status
git
Launchpad, Ubuntu, Debian
Upstream
Released (1:2.24.0-2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:2.17.1-1ubuntu0.5)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:2.7.4-0ubuntu1.7)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist