CVE-2019-13602

Published: 14 July 2019

An Integer Underflow in MP4_EIA608_Convert() in modules/demux/mp4/mp4.c in VideoLAN VLC media player through 3.0.7.1 allows remote attackers to cause a denial of service (heap-based buffer overflow and crash) or possibly have unspecified other impact via a crafted .mp4 file.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
vlc
Launchpad, Ubuntu, Debian
Upstream
Released (3.0.7.1-2)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(3.0.7.1-3)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.0.7.1-3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.0.7.1-0ubuntu18.04.1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://git.videolan.org/?p=vlc.git;a=commit;h=8e8e0d72447f8378244f5b4a3dcde036dbeb1491
Upstream: https://git.videolan.org/?p=vlc.git;a=commit;h=b2b157076d9e94df34502dd8df0787deb940e938